Guest Admin Access

Incident Report for Drata

Resolved

Our team released an update to address this issue. Guest Admins should now be able to view clients within "Business Accounts" as expected.
Posted Mar 16, 2026 - 12:16 PDT

Identified

Our team has identified a fix for this issue. We will reach out to update you upon deployment. Thank you for your continued patience.
Posted Mar 16, 2026 - 09:55 PDT