Bulk Actions on Personnel Degraded

Incident Report for Drata

Update

We've identified an issue with 'Bulk Actions' button on Personnel page and have temporarily disabled this functionality while we work on a resolution.
Posted Jun 22, 2026 - 11:02 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2026 - 11:01 PDT