Risk Management displaying outdated data

Incident Report for Drata

Resolved

The incident is resolved
Posted Dec 09, 2025 - 14:37 PST

Monitoring

A fix for the issue where Risk Management was displaying outdated data has been deployed. Team is monitoring to make sure that the issue has been resolved.
Posted Dec 09, 2025 - 04:25 PST

Investigating

Some customers may see outdated information displayed in the risk management module. Our team is actively working to resolve the issue as quickly as possible.
Posted Dec 08, 2025 - 21:52 PST